Jump to content

Recommended Posts

@kylek29 I have been using your scripts as hotbutton on the montage but I am considering a streamdeck. Am I correct that you are using one? The xl? Also you mentioned premarket keys? Is the difference the type of stop? Is there a new spreadsheet with premarket scripts. Thank for all you help creating the risk limiting scripts.

Share this post


Link to post
Share on other sites
On 1/12/2021 at 12:15 PM, ChrisReath said:

Does anyone have the issue where the Stream Deck just won't execute sometimes?  I'll press a button to "Sell 20%" for some reason and it just won't execute, and I'll have to resort to clicking the button on the montage.  A short time later it will start working again.

Curious if you ever found an answer to your problem. I just got a Stream Deck and have noticed the same issue. Sometimes it works, sometimes it doesn't.

Share this post


Link to post
Share on other sites
3 hours ago, Wildfire said:

Curious if you ever found an answer to your problem. I just got a Stream Deck and have noticed the same issue. Sometimes it works, sometimes it doesn't.

Sometimes this happens to me as well and typically it is because I do not have the correct window (montage) selected.  If I click back in to the proper window, the Stream Deck fires away.

Share this post


Link to post
Share on other sites
13 hours ago, Wildfire said:

Curious if you ever found an answer to your problem. I just got a Stream Deck and have noticed the same issue. Sometimes it works, sometimes it doesn't.

I've never had that issue, but I do have a command to focus the applicable montage as a prefix for all applicable hot keys. This does make using multiple montages for orders more tricky (could use multiple layouts though) but in my case I use one montage for orders, the others for info only. 

It's also worth checking:

1) That its not an issue with placing the order (due to various constraints,  hot key script issue etc) as shown by a warning message in the montage which is often easy to miss.

2) There isn't some other software on your PC setting global hotkeys intermittently.  This is generally poor/buggy design but I've used a few utilities that register global hotkeys only when not minimized or performing some action (but not focused).  

Share this post


Link to post
Share on other sites

Thanks DanT and smp. I do have multiple montages. I typically double click the chart associated with the montage to select my stop loss which usually activates the montage and makes it the focused window. I'll try to pay close attention to see if for some reason the montage does not become the focused window after double clicking my chart to set my stop loss price. 

Share this post


Link to post
Share on other sites
11 hours ago, Wildfire said:

Thanks DanT and smp. I do have multiple montages. I typically double click the chart associated with the montage to select my stop loss which usually activates the montage and makes it the focused window. I'll try to pay close attention to see if for some reason the montage does not become the focused window after double clicking my chart to set my stop loss price. 

Update. Definitely user error on my part. I noticed that sometimes my "double clicks" on the chart were more like "triple clicks" due to trying to be too quick. When I accidentally triple click, the first two clicks selects my stop and puts the montage in focus, but then the inadvertent third click then puts my chart in focus which makes the stream deck unresponsive. 

So problem solved. Thanks again for the feedback.

Share this post


Link to post
Share on other sites

I found a possible solution for the problem, that some users had here before. Stream Deck worked with all the software but not with DAS Trader. (there are several posts in this topic but no solution).

I bought Stream Deck today and had the same problem. Everything worked but DAS did not react at all. I found out, that it was started in Administrator mode (I had issues in saving the configuration and desktop because of folder privileges and this is one of the solutions provided by DAS - start it in Administrator mode).

When I start DAS in "normal" mode, Stream Deck works with it perfectly.

Edited by Konrad

Share this post


Link to post
Share on other sites
4 hours ago, peterB said:

i tried the same hotkey script as a hot button anyway and no issues. i used the hotkeys for more than a year so not a das problem but something between windows and streamdeck. anybody experienced something like this yet?

No issues here.

As the streamdeck is just sending the keypress combination to trigger the same script that's very odd unless the focus wasn't where it should be or there is some UI timing issue.

If the hotkey script includes a focus montage command it could be DAS hasn't completed that in time,  but for it to go from long term reliable to having issues would imply a change in DAS or something else on your PC hooking windows messages and somehow impacting the operation timing during the script.  If DAS is using values read from the UI controls directly during script execution as opposed to internal copies of those values that would make it more prone to issues from timing/external factors due to the message driven UI updates but I've not experienced any problems and I would hope DAS have written their code to prevent this.

Have you installed/updated any other software recently (including drivers) or DAS? Do you have any external scripts that manipulate DAS UI or linkage from apps like TI?

Share this post


Link to post
Share on other sites
On 5/15/2018 at 8:02 AM, Jason H. said:

I LOVE my streamdeck. I've got mine configured with multiple screens for short and long positions in different sizes. I have the controls nested and color coded so I don't mistakenly short when I mean to go long, or to large when I mean to go small size. You can see pictures in the "show us your setup" thread. Here is my icon set if you want to use it.

Thanks buddy

Share this post


Link to post
Share on other sites
Posted (edited)
On 10/10/2018 at 9:48 PM, KyleK29 said:

Here's a screenshot of how I do it. You'll notice I have the button mapped to: CTRL+ALT+PgDown (ignore the title of F1, I never changed it). In the Settings > Profiles > I have a "Day Trading" profile configured and Application set to "None." 

Also note that DAS doesn't appear to support certain key presses (F13 to F24).

I also uploaded my DayTrading profile here if you want to see it: https://mega.nz/#!Wgl2mA6a!l8cCkSJnh1c7eD6bK6VM2yE5U_DgfAd-9uAs8qEuGvw

You'd have to unzip the profile and import it.

2018-10-10_18-41-28.jpg

@KyleK29 - Would you be able to share your day trading profile file for the stream deck? the above link looks expire. - Thank you!

Edited by You vs You

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.