Jump to content
Bargeguy

Thor's (Kyle's) Hot Key

Recommended Posts

I have cut and pasted Thor's hot key for Buy $40 which sets the share size based on a $40 risk onto a hot button in my montage.  I am trading with IBK using DAS Trader Pro and I have checked the double click to trade box in config.  I have tested the scrip in sim during trading hours but I can't seem to make it work.  I assume that I am doing something mechanically wrong but really don't know.  Based on a video I watched by John H. I am doing the following:

First I double click on the chart at my desired stop price then I push the Buy $40 hot key.  When I do this, the program buys the shares but does not set the stop.  I have tried this 4 or 5 times but when the current price reaches a $40 loss, the position does not close.  

Can you tell me what I should do?  I'm attaching the script which should look familiar (the red 40 is black in my hot button script) .  Thank you very much in advance. 

 

Buy $40

StopPrice=Price-0.01;DefShare=BP*0.97;Price=Ask-Price+0.01;SShare=40/Price;Share=DefShare-SShare;DefShare=DefShare+SShare;SShare=Share;Sshare=DefShare-SShare;Share=0.5*SShare;TogSShare;ROUTE=SMRTL;Price= Ask+0.05;TIF=DAY+;BUY=Send;DefShare=400;TriggerOrder=RT:STOP STOPTYPE:MARKET PX:StopPrice-0.1 ACT:SELL STOPPRICE:StopPrice QTY:Pos TIF:DAY+;

Van Janssen - Bargeguy

 

 

Share this post


Link to post
Share on other sites
On 11/11/2021 at 7:51 AM, Bargeguy said:

Can you tell me what I should do?  I'm attaching the script which should look familiar (the red 40 is black in my hot button script) .  Thank you very much in advance. 

SIM or LIVE ?

Broker ?

Is double to trade ON ?

Version of DAS ?

 

Share this post


Link to post
Share on other sites
On 11/11/2021 at 1:51 PM, Bargeguy said:

Can you tell me what I should do?

make sure to read the instructions for usage and known issues in the first post and do the necessary steps.


+ it works only in market hours, not in replay mode
+ make sure you have buying power (BP) on your account (you obviously have)
+ use existing topics for troubleshooting, 99% of things you may come up has been discussed already and creating another topic with the same problem does not help others

 

Edited by peterB

Share this post


Link to post
Share on other sites

I have tried it in SIM, the double click to trade is checked in config, mybroker is IBK, my version was 5.6.4.13 but after reading your post I updated to 15 and am now current.   

I have tried it during market hours in sim (shown above) and confirm that I have adequate buying power.  

I feel like that I have the correct script but that I am doing something mechanically wrong. 

To review, I double click on my stop price then I push the Buy $40 button.  The program calculates the number of shares and buys the stock at the market but the stop price doesn't engage so if I lose $40 or more, the program does not sell the stock.  It's probably something very simple but I don't know what it is.  Maybe updating my DAS program will make it work so I'll try that on Monday but if there's some step I'm missing please advise.  I admit to being dumber than a rock when it comes to the finer points of this stuff so don't be shy about asking me about simple things like is my computer turned on-I did check and it is 🙂.  

  Thanks very much for taking the time to help me. 

Bargeguy 

(Van Janssen)  

Share this post


Link to post
Share on other sites

I'm not familiar with that.  When I opened the Level 2 config I didn't see anything that referred to style settings.  Where do I access those settings and what should they be?  

Thanks very much,

Bargeguy

Van 

Share this post


Link to post
Share on other sites

that is why i referred you to the known issues on that topic - its written there

Share this post


Link to post
Share on other sites
21 minutes ago, Bargeguy said:

I'm not familiar with that.  When I opened the Level 2 config I didn't see anything that referred to style settings.  Where do I access those settings and what should they be?  

Thanks very much,

Bargeguy

Van 

Hello,

Below screenshot is showing part of the Montage window. You can right click on any empty space on the Montage> then click on style to select desire Montage Style "Stop Order" for your script to work. If you read Kyle's post, you will get the details also.

image.png.c5b1464ed1bd6740664dbeff7e1fcd77.png

Best of luck.

Share this post


Link to post
Share on other sites

Thank you gentlemen for all your help.  I've made the changes and I am itching try them out tomorrow morning.  I couldn't have done it without your generous advice.  Now I'm going to start at the beginning of this thread and try to absorb all the great hotkey and other ideas that have been developed for all of us.  Another reason to go with BBT, I can't imagine this level of help and just plain kindness anywhere else.  

Bargeguy

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.