Jump to content

Recommended Posts



I'm having issues with hotkeys in DAS. I just want to place long or short orders for 100, 200, 300 shares etc. Then I want to be able to place a Stop Loss about 20 cents away from my position. I also use the Move Stop To Breakeven script. I also use sell/cover 5%, sell/cover all hotkeys. When I place a long order of say 100 shares, it works fine. Then I use the Add Stop Loss - 20 cents hotkey which works fine too. However, after adding this, it then changes the montage order to "Stop" permanently and I have to manually go in and change back to limit. After adding the S/L, if I press Buy 100 shares, it comes up as an OCO order.  If I try to sell the 100 shares using my sell hotkey, it also comes up as an OCO. I just want to place simple orders but seems like either I'm missing something or DAS is just awkward to use. Also, after using breakeven hotkey, it does the same and rejects my order when I try to sell/cover positions. Some help would be much appreciated as the only way around this is to change ticker then change back to the ticker which I have a position in to refresh the montage, but this could lose precious seconds! Below are my hotkeys:


Long 100 Shares:


Short 100 Shares:


Sell 5%


Cover 5%


Add Stop Loss -20 cents


Move S/L to breakeven


Share this post

Link to post
Share on other sites

multiple issues here.

the order rejection is probably because of the existing orders. you need to cancel the existing stop orders first before placing a new one, otherwise you can hit the buying power limit

the other issue might be a subject of the default trading preset or can be probably fixed by addin some dummy order at the end of your stop loss order hotkey.

you might reconsider completely your usage of the hotkeys - like i explain here https://traderpeter.substack.com/p/das-trader-advanced-hotkeys-part

Share this post

Link to post
Share on other sites

Great thanks for your help! I've tried out your Stop loss hotkey which works great but still trying to figure out how to avoid the montage order rout changing to stop, any ideas? Not sure if there is a way to permanently set the order route to Market?

Share this post

Link to post
Share on other sites

you can add a route=SMRTL; at the end of each of your scripts. i am affraid that the idea behind your requirement is false

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.