Jump to content
Monk

Trading Montage "active" to place a trade...

Recommended Posts

Does the Trading Montage screen have be the "active" window (meaning the one that is selected) in order to use the Hot Keys to place a trade? I've noticed that sometimes I hit my Hot Keys and nothing happens. I think what I'm doing is messing around in my 1m chart and making that window active instead of the Montage window. Thanks.

Share this post


Link to post
Share on other sites

Yes, the Montage has to be active for hotkeys to work. There is an option to double-click the chart to make the Montage active.

 

Right-click chart > Config > Double click to trade (bottom right)

Share this post


Link to post
Share on other sites

Also, when your montage is selected, whether you select it by clicking on the montage, double clicking the chart linked to it, or having a hotkey,

for me at least, it automatically selects the montage AS WELL AS highlights the ticker symbol field within the montage.

 

So lets say I am in a position, ready to get out, select my montage, but then accidentally press some random key, it will change the ticker symbol and

when i try to place a trade, a notification message comes up. . .

 

"This order will be placed for symbol "AAA" (whatever your chart is on), but currently symbol "?" is entered in the symbol text box. Continue?"

 

So its great that DAS is trying to do the right thing, but in the heat of the moment, and especially if you have never seen this message and unaware of

exactly what happened it can be a big distraction at the perfectly wrong time. Hope this saves anyone from the fate it caused me first time I experienced it.

  • Like 2

Share this post


Link to post
Share on other sites

AdventureDogLA I've had the same thing happen. Drives me crazy and wish DAS would treat this as an issue.

Share this post


Link to post
Share on other sites

@Wpicotte, I feel yah. Since DAS probably wont treat that issue any time soon. I made "hotkey/button mistakes" as part of my trading plan. So now I am 100% accountable and give myself high scores for having no "hotkey/button mistakes" per day and week.

Share this post


Link to post
Share on other sites

What about using the SwitchTWnd command inside your order commands like so:

SwitchTWnd;ROUTE=SMRTL;Share=100;Price=Ask+0.10;TIF=GTC;BUY=Send

This would make sure the Montage is activated everytime you wanna send an order I think.  I havent tried it tho...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.